Windows 8.1 unable to install .NET Framework 3.5 0*800F0906

I inserted windows 8.1 dvd and mounted to d drive then executed from powershell.

  1. Open admin command prompt
  2. Type powershell
  3. From ps prompt type

Enable-WindowsOptionalFeature -Online -FeatureName 'NetFx3' -Source 'd:\sources\sxs'

  1. It did take 5 minutes to run.

See http://yellowduckguy.wordpress.com/2012/10/19/windows-8-fix-enable-feature-net-3-5-error-0x800f0906/ for a detailed description.

Enter in cmd (run with administratoir rights): dism /online /Enable-Feature /FeatureName:NetFX3 /All /Source:E:\Sources\SxS /LimitAccess (e: is your DVD drive)


You probably have a GPO that blocks updates directly from Microsoft. Did not check the WSUS server to see if the required packages were present. Simply made these registry changes and the PC was able to pull down the updates. Note, no need to undo these as the GPO will do it for you.

----- Below this line is the actual content to create your own .REG file -----

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\WindowsUpdate]
"DisableWindowsUpdateAccess"=dword:00000000
"DisableWindowsUpdateAccessMode"=dword:00000000

Found link that identifies two Windows Updates as the problem if DISM and the offline installer do not work. Uninstall KB2966826 and KB2966828, then try installing 3.5 from programs and features. It worked for me.

By Chris Wardario


I had to log in as a local admin account, rather than runas to get it to download the missing binaries.


Comments

  1. Judah

    • 2019/11/24

    I inserted windows 8.1 dvd and mounted to d drive then executed from powershell. Open admin command prompt; Type powershell; From ps prompt 

  2. Kylen

    • 2019/11/27

    Cause: under gpeditor, MS update service location was set to some local WSUS. Solution: copy that URL and set MS update service location disable or Not configured from gpeditor. now try steps from feature on/off Windows to install .Net Framework 3.5. after successfully completion revert WSUS update service URL.

  3. Oakley

    • 2015/1/5

    NET install problems by installing FEATURES ON DEMAND on your companies WSUS server. NET 3.5 on Windows 8 or 8.1 and end up with errors like 0x800F0906 and 

  4. Huxley

    • 2016/6/1

    1. Navigate to the Add Windows Features window: From the Windows Start Page, right-click on any open space and click on 'All apps'. Go to the Control Panel and choose 'Programs and Features' Choose 'Turn Windows features on or off' in the Programs and Features window. 2. Turn on the .NET Framework 3.5 feature: The '.NET Framework 3.5 (includes .NET 2.0 and 3.0)' option is not be selected.

  5. Lyle

    • 2019/12/16

    Windows 8 is not able to connect to the Windows servers to download and install .NET 3.5 content. Solution or Workaround. This solution requires the user to 

  6. Preston

    • 2016/7/7

    These errors may occur when you use an installation wizard, the Deployment Image Servicing and Management (DISM) tool, or Windows PowerShell commands to enable the .NET Framework 3.5. In Windows 10, Windows 8.1, Windows 8, Windows Server 2012 R2, and Windows Server 2012, the .Net Framework 3.5 is a Feature on Demand.

  7. Peterson

    • 2019/2/22

    NET Framework 3.5 in Windows 8/8.1, they receive following error My error code is 0*800F0906 please help me to remove this error and fix 

  8. Conrad

    • 2020/2/11

    Hi FlippinWindows will be relaunching its channel in April 2014 with so much cool stuff in Windows Tech and you are invited to be a member by subscribing. Re

  9. Genesis

    • 2019/10/2

    I inserted windows 8.1 dvd and mounted to d drive then executed from powershell. Open admin command prompt; Type powershell; From ps prompt type.

  10. Begu

    • 2021/3/19

    dism /online /Enable-Feature /FeatureName:NetFX3 /All /Source:E:\Sources\SxS /LimitAccess. Hit enter once you have completed the command. Below is a screenshot of what this will look like when you hit enter. Now your Windows Feature of .NET Framework 3.5 (includes .NET 2.0 and 3.0) is enabled.

  11. Jackson

    • 2015/5/9

    If you are unable to install .NET 3.5 on Windows 8 or 8.1 and end up with errors like 0x800F0906 and 0x800F081F you will find that errors relate to corrupt or 

  12. Henrik

    • 2016/3/26

    NET Framework 3.5 within Windows 8 / 8.1 / 10 to resolve potential application compatibility issues. Issue installing applications that need .

Comments are closed.

Recent Posts